FAQs

From CometWiki

Jump to: navigation, search

Contents

FAQs

Where are all the various log files?

When troubleshooting problems with your Comet installation, a good first place to start is with the appropriate log file. Below we'll tell you where the default locations of the files are. But you can control the location of the Comet logs by creating a %COMETDATA% environment variable. This does not apply to the Comet Services log files.

Here is a list of the log files and their default locations:

The Comet Log
Normally the easiest way to find the Comet log is to click on the "System Logs" button on the QMONITOR screen. This will open Windows Explorer to the folder containing the log. It will have all of the log information since the last time the log file was either erased or truncated. If you only need to see the log for the current Comet session just click on View->Comet log at the top of your Comet window (full Comet sessions only).

If you can't even run Comet and you need the log, click on the "Details" button at the bottom right corner of the splash screen when you attempt to run Comet. When the log display opens up, click on File->Open log file. It will open up in your text editor.

Another way to find the path to the Comet log file is to look at the value assigned to your LOGS alias. Click on Edit->Directory Aliases at the top of your Comet window to view the path.

If you are using the /log command line argument on your Comet shortcut then the Comet log will be in the user's temp folder (%temp%). It'll be called [profile].log, where [profile] is the Comet profile name matching the /PN= command line argument.

The CosP Log
For printing problems this is the first place to look. You'll find it in the same folder as the Comet log (above). In some error situations you will see a message to find additional information in CosPErr.log. Follow the path in the error message to retrieve that file as well.
In order to get the printing logs you must turn on the logging option in your CosW.ini. See info below about where to find CosW.ini and where to find a list of the settings.

The Comet Services Logs
Both the Security Server and the File Server produce logs which may be helpful in troubleshooting problems. You'll find the logs in a folder called LOGS in your Comet Services folder.

The current Security Server log is called CSecSrv.log. Each time you restart the Security Server a new log is started so that seven generations of logs are kept. They are named CSecSrvN.log, where N is a number from 1 to 6.

The current file server log is called CometSrv.log. Each time you restart the File Server a new log is started so that seven generations of logs are kept. They are named CometSrvN.log, where N is a number from 1 to 6. The log is only created if you have logging turned on. You'll need administrative privileges to turn logging on. From the file server console, click on View->Properties. (If the dialog is disabled, you'll need to restart the console using "Run as administrator".) Check the "Log Messages" box under "Diagnostic Logging". Select the "All Messages" radio button. The top half of the properties dialog lets you choose which functions will generate log entries. Unless you are troubleshooting a particular function we recommend you choose the "Show None" button. This will restrict logging to just logins and logouts and any error messages that occur. Adding additional functions to the logging can impact file server performance.

The XAP Log
An XAP log is only generated if you have a LOGFILE statement in your #XAP file. The LOGFILE specifies where to find the log.

Where can I find my CosW.ini file?

If you can find your Comet.log file, finding CosW.ini is really easy. Navigate one folder up from the folder containing the Comet.log file. You'll find CosW.ini there. This is true even if you are using the %COMETDATA% environment variable. This file contains important settings for how your Comet session and printing will be handled. You can find out about those settings here [[1]]

What ports are used by Signature Systems software?

You can find a list of ports here [[2]]

I'm getting an error message that CometLib couldn't be registered. What should I do?

The CometLib dll should register automatically when you start Comet. If not, there are a couple of things to try.
First, right-click your Comet shortcut and select "Run as administrator". If CometLib registers successfully, you can run Comet normally from now on.
If that was unsuccessful then you can try to register it manually. It needs to be registered for the user's temp folder. To do that, get to the Windows command prompt by running cmd.exe. Change to the temp folder by typing cd %temp%. Now you can register CometLib by typing regsvr32 cometlib.dll

Will the Comet Services run on a virtual server?

Yes as long as the server is running a supported version of Windows [[3]]. You will probably want to consider using a virtual dongle for your Comet security. Here's a link to info about the virtual dongle: [[4]]

How can I get the latest license certificate for my security token?

There are a couple of ways. First if you are able to run Comet you can use the SecLic utility. This requires a WinSock gateway in your configuration. If you are running Comet32, SecLic has been replaced by SecSrv. The WinSock gateway is automatically configured for you in Comet32.

If you can't run Comet at all, you can still get the latest license. For Server versions prior to 16.00, stop the Comet Services. Erase the license.txt and any [plugnumber].txt files from your Comet Services folder. When you restart the Comet Services the Security Server will automatically connect to our server to get the license if one is not found in your folder.
If you're running Comet Services 16.00 or later, it's even easier. From the Security Server console, click Edit->Update licenses. Now click the "Update Certificate" button. Your certificate will be retrieved and installed for you.
These methods work for parallel, USB, and virtual dongles.

Should I run Comet16 or Comet32?

Comet16 can only be run on 32-bit versions of Windows and it has been retired. No further work will be done on it. We recommend you run Comet32.

If you are running a 64-bit version of Windows, Comet32 will run automatically. On 32-bit versions of Windows you can request Comet32 by including /32 on your Comet shortcut command line: c:\comet\comet.exe /pn=nodename /32
If you want to make sure all Comet clients on the network are running Comet32, just set ForceC32 = 1 in your CosWGlob.ini file [[5]]

Other things to consider:
Comet16 can run programs compiled for Comet16. It can also run programs compiled for Qantel computers.
Comet32 can run programs compiled for Comet16 and programs compiled for Comet32.

Check the Systems Requirements chart for Comet compatibility with the various versions of Windows

Note: 64-bit CometAnywhere clients can run their Comet session from a Comet16 CA host. In an environment where factors are preventing deployment of Comet32 at this time, this is a way you can run Comet16 on computers that otherwise could only run Comet32.

How can I tell if a program was compiled for Comet16 or Comet32?

There are several ways.

  • CometExplorer's TYPE column indicates the type of object file: C16 Program, C32 Program, or C32M Program (Comet Mobile)
  • When you run a program in Comet32 a colored block on the window's status line indicates the type of program: purple for Comet16; green for Comet32
  • From inside your program you can use FSTAT on an object file to determine if it was compiled for Comet16 or Comet32. Look in position 135 [[6]]
  • PSTAT can also be used to check the type of a program that's currently running. Look in position 219 [[7]]
  • If you attempt to run a Comet32 program in Comet16 you will get an Error 63.

Can I use the Comet16 compiler on a 64-bit computer?

No, you can only run the Comet16 compiler from a computer that can run Comet16. When compiling from UltraEdit, either the Comet16 compiler or the Comet32 compiler will be launched depending on the version of Comet currently running on the host computer. So, on a 32-bit computer you can compile with either the Comet16 compiler or the Comet32 compiler, but on a 64-bit computer you can only compile with the Comet32 compiler.

Personal tools